You are here: Home > Academics > Library > infoRM

 

Technical Specifications

Before you continue check the requirements below. If you have any problems, contact the IT Help Desk.

plug in

1. Browser

You need a recent version of any browser, such as Mozilla Firefox, Safari, or Internet Explorer. If you need a more current version, you can download it, free, from their site.

2. Plug-ins

To experience all the effects, you'll need the Shockwave Flash plug-in, a free application that enhances your browser and makes this site interactive. If you can see the animation below...

Content on this page requires a newer version of Adobe Flash Player.

Get Adobe Flash player

...you already have the plug-in. If you can't see anything, go to the Macromedia Flash Player Download Center and follow their downloading directions. Or, you can click on "Non-Flash Version", whenever you get to a Flash page.

 

Resources for Librarians and Educators, Credits
Original InfoRM material © 2011 by the Liberty University Jerry Falwell Library. This tutorial incorporates material from SBU Library Research Guide, a tutorial developed by the Stony Brook University Libraries, © 2004, from Inflite, a tutorial developed by IUPUI, © 2003, from Searchpath, a tutorial developed by the Western Michigan University Library, © 2001-2002, and from TILT, a tutorial developed by the Digital Information Literacy Office for the University of Texas System Digital Library, © 1998-2002. This material may be reproduced, distributed, or incorporated, provided that appropriate credit is given.